1. 8.5.x core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php ContextAwarePluginBase::context
  2. 8.0.x core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php ContextAwarePluginBase::context
  3. 8.1.x core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php ContextAwarePluginBase::context
  4. 8.2.x core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php ContextAwarePluginBase::context
  5. 8.3.x core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php ContextAwarePluginBase::context
  6. 8.4.x core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php ContextAwarePluginBase::context
  7. 8.6.x core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php ContextAwarePluginBase::context

The data objects representing the context of this plugin.

Type: \Drupal\Component\Plugin\Context\ContextInterface[]

File

core/lib/Drupal/Component/Plugin/ContextAwarePluginBase.php, line 20

Class

ContextAwarePluginBase
Base class for plugins that are context aware.

Namespace

Drupal\Component\Plugin

Code

protected $context = [];